// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\w+)?'(?:\w+)?").unwrap();
let string = "I've never 'had somebody [redacted-number] [redacted-number] [redacted-number] not. not' you're 123'45";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}