re = /(?:\w+)?'(?:\w+)?/m
str = 'I\'ve never \'had somebody [redacted-number] [redacted-number] [redacted-number] not. not\' you\'re 123\'45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end