using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"create(Lazy)?FileRoute(\(\s*['""])([^\s]*)(['""],?\s*\))";
string input = @"createFileRoute(`/about`)
createLazyFileRoute(`/about`)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}