use strict;
my $str = '010036838277501621307002621717551723063010O100050
010030054474225221100684537946921723083110AB5432B
01003005447422522110068453794692~1723083110AB5432B';
my $regex = qr/(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}