import Foundation
let pattern = #"(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
010036838277501621307002621717551723063010O100050
010030054474225221100684537946921723083110AB5432B
01003005447422522110068453794692~1723083110AB5432B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)