import re
regex = re.compile(r"(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})", flags=re.MULTILINE)
test_str = ("010036838277501621307002621717551723063010O100050\n"
"010030054474225221100684537946921723083110AB5432B\n"
"01003005447422522110068453794692~1723083110AB5432B")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")