package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\h*([^\w\s]+(?:\h+[^\w\s]+)*)\h*`)
var str = `test! one.two .three; four, five . six. .seven`
var substitution = "$1 $2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}