$re = '/(\w+)\h*([^\w\s]+(?:\h+[^\w\s]+)*)\h*/m';
$str = 'test! one.two .three; four, five . six. .seven';
$subst = "$1 $2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;