const regex = /(\w+)\h*([^\w\s]+(?:\h+[^\w\s]+)*)\h*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\h*([^\\w\\s]+(?:\\h+[^\\w\\s]+)*)\\h*', 'mg')
const str = `test! one.two .three; four, five . six. .seven`;
const subst = `$1 $2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);