const regex = new RegExp('^(\\s+)?(.*?)(\\s+\\/.*)$', 'gm')
const str = ` 123 / some text 123
anything else / some text 123
123 / some text 123
anything else / some text 123`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);