$re = '/^(\s+)?(.*?)(\s+\/.*)$/m';
$str = ' 123 / some text 123
anything else / some text 123
123 / some text 123
anything else / some text 123';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;