import re
regex = re.compile(r"^(\s+)?(.*?)(\s+\/.*)$", flags=re.MULTILINE)
test_str = (" 123 / some text 123\n"
" anything else / some text 123\n"
"123 / some text 123\n"
"anything else / some text 123")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)