#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(?=\s*(?:\bFeaturing\b|[&,]|$))"
Local $sString = "Drake" & @CRLF & _
"Post Malone Featuring Ty Dolla $ign" & @CRLF & _
"BlocBoy JB Featuring Drake" & @CRLF & _
"Offset & Metro Boomin" & @CRLF & _
"Jay Rock, Kendrick Lamar, Future & James Blake"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")