re = /^.*?(?=\s*(?:\bFeaturing\b|[&,]|$))/m
str = 'Drake
Post Malone Featuring Ty Dolla $ign
BlocBoy JB Featuring Drake
Offset & Metro Boomin
Jay Rock, Kendrick Lamar, Future & James Blake'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end