import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?=\\s*(?:\\bFeaturing\\b|[&,]|$))";
final String string = "Drake\n"
+ "Post Malone Featuring Ty Dolla $ign\n"
+ "BlocBoy JB Featuring Drake\n"
+ "Offset & Metro Boomin\n"
+ "Jay Rock, Kendrick Lamar, Future & James Blake";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}