using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=\""([^\""]*?)\""((?!href).)*?(?=keyword)";
string input = @"href=""something "">
href=""something else"">
href=""INeedThis""> // <- i need this
keyword
href=""something else"">
href=""something else"">
keyword
href=""something else"">
keyword
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}