$re = '/href=\"([^\"]*?)\"((?!href).)*?(?=keyword)/s';
$str = 'href="something ">
href="something else">
href="INeedThis"> // <- i need this
keyword
href="something else">
href="something else">
keyword
href="something else">
keyword
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);