const regex = /href=\"([^\"]*?)\"((?!href).)*?(?=keyword)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=\\"([^\\"]*?)\\"((?!href).)*?(?=keyword)', 'gs')
const str = `href="something ">
href="something else">
href="INeedThis"> // <- i need this
keyword
href="something else">
href="something else">
keyword
href="something else">
keyword
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}