import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "C.*?;";
final String string = "C:\\Program Files\\ConEmu\\ConEmu\\Scripts;C:\\Program Files\\ConEmu;C:\\Program Files\\ConEmu\\ConEmu;C:\\Program Files\\AdoptOpenJDK\\jre-11.0.4.11-hotspot\\bin;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Microsoft VS Code\\bin;C:\\Program Files (x86)\\PDFtk\\bin\\;C:\\Program Files\\ffmpeg\\bin;C:\\Program Files\\ffmpeg\\avconv\\bin;C:\\Program Files\\ffmpeg\\curl\\bin;C:\\Program Files\\nodejs\\;C:\\Program Files\\Git\\cmd;C:\\Program Files (x86)\\Gpg4win\\..\\GnuPG\\bin;C;C:\\Users\\jc\\AppData\\Local\\Programs\\Python\\Python38-32\\Scripts\\;C:\\Users\\jc\\AppData\\Local\\Programs\\Python\\Python38-32\\;C:\\Users\\jc\\AppData\\Roaming\\npm;C:\\Program Files\\OpenSSH;C:\\Users\\jc\\.ssh;C:\\Program Files (x86)\\Nmap;C:/Users/jc/AppData/Local/Programs/Python/Python38-32/python.exe;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}