# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"C.*?;"
test_str = "C:\\Program Files\\ConEmu\\ConEmu\\Scripts;C:\\Program Files\\ConEmu;C:\\Program Files\\ConEmu\\ConEmu;C:\\Program Files\\AdoptOpenJDK\\jre-11.0.4.11-hotspot\\bin;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Microsoft VS Code\\bin;C:\\Program Files (x86)\\PDFtk\\bin\\;C:\\Program Files\\ffmpeg\\bin;C:\\Program Files\\ffmpeg\\avconv\\bin;C:\\Program Files\\ffmpeg\\curl\\bin;C:\\Program Files\\nodejs\\;C:\\Program Files\\Git\\cmd;C:\\Program Files (x86)\\Gpg4win\\..\\GnuPG\\bin;C;C:\\Users\\jc\\AppData\\Local\\Programs\\Python\\Python38-32\\Scripts\\;C:\\Users\\jc\\AppData\\Local\\Programs\\Python\\Python38-32\\;C:\\Users\\jc\\AppData\\Roaming\\npm;C:\\Program Files\\OpenSSH;C:\\Users\\jc\\.ssh;C:\\Program Files (x86)\\Nmap;C:/Users/jc/AppData/Local/Programs/Python/Python38-32/python.exe;"
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.