$re = '/C.*?;/mi';
$str = 'C:\\Program Files\\ConEmu\\ConEmu\\Scripts;C:\\Program Files\\ConEmu;C:\\Program Files\\ConEmu\\ConEmu;C:\\Program Files\\AdoptOpenJDK\\jre-11.0.4.11-hotspot\\bin;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Microsoft VS Code\\bin;C:\\Program Files (x86)\\PDFtk\\bin\\;C:\\Program Files\\ffmpeg\\bin;C:\\Program Files\\ffmpeg\\avconv\\bin;C:\\Program Files\\ffmpeg\\curl\\bin;C:\\Program Files\\nodejs\\;C:\\Program Files\\Git\\cmd;C:\\Program Files (x86)\\Gpg4win\\..\\GnuPG\\bin;C;C:\\Users\\jc\\AppData\\Local\\Programs\\Python\\Python38-32\\Scripts\\;C:\\Users\\jc\\AppData\\Local\\Programs\\Python\\Python38-32\\;C:\\Users\\jc\\AppData\\Roaming\\npm;C:\\Program Files\\OpenSSH;C:\\Users\\jc\\.ssh;C:\\Program Files (x86)\\Nmap;C:/Users/jc/AppData/Local/Programs/Python/Python38-32/python.exe;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);