using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p\s*class=""translate""[^>]*>[^<>]*<strong>[\S\s]*?<\/strong>(*SKIP)(*F)|strong>";
string input = @"<p class=""translate"" style=""font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;""><strong><span style=""color: blue;"">Lorem</span><br><span style=""color: navy;"">ipsum</span></strong>
</p></div>
<p style=""font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;""><strong><span style=""color: blue;"">Lorem</span><br><span style=""color: navy;"">ipsum</span></strong>
</p>
stronger
strongest
<span style=""color:blue;font-weight:bold;"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}