import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p\\s*class=\"translate\"[^>]*>[^<>]*<strong>[\\S\\s]*?<\\/strong>(*SKIP)(*F)|strong>";
final String string = "<p class=\"translate\" style=\"font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;\"><strong><span style=\"color: blue;\">Lorem</span><br><span style=\"color: navy;\">ipsum</span></strong>\n"
+ "</p></div>\n"
+ "<p style=\"font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;\"><strong><span style=\"color: blue;\">Lorem</span><br><span style=\"color: navy;\">ipsum</span></strong>\n"
+ "</p>\n"
+ "stronger\n"
+ "strongest\n"
+ "<span style=\"color:blue;font-weight:bold;\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}