# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p\s*class=\"translate\"[^>]*>[^<>]*<strong>[\S\s]*?<\/strong>(*SKIP)(*F)|strong>"
test_str = ("<p class=\"translate\" style=\"font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;\"><strong><span style=\"color: blue;\">Lorem</span><br><span style=\"color: navy;\">ipsum</span></strong>\n"
"</p></div>\n"
"<p style=\"font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;\"><strong><span style=\"color: blue;\">Lorem</span><br><span style=\"color: navy;\">ipsum</span></strong>\n"
"</p>\n"
"stronger\n"
"strongest\n"
"<span style=\"color:blue;font-weight:bold;\">")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.