$re = '/(?:^\s+map_K.\s+)([^\x00-\x1F\x7C]+)$/m';
$str = ' map_Ks ./CarbonFiber_T.tga';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);