re = /(?:^\s+map_K.\s+)([^\x00-\x1F\x7C]+)$/m
str = ' map_Ks ./CarbonFiber_T.tga'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end