import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^-]*)->.*?(\\[[^]]*\\]);$";
final String string = "class1->Signal = sample1_sample2.sample3_sample4[4:4];\n"
+ "class2->Signal = sample1.sample2.sample3_sample4_sample5[2];\n"
+ "class3->Signal = sample1+sample2_sample3.sample4.sample5sample7[7:3];\n"
+ "class4->Signal = sample1[1]+sample2_sample3.sample4.sample5sample7[7:3];";
final String subst = "$1 bit = $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}