const regex = /^([^-]*)->.*?(\[[^]]*\]);$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^-]*)->.*?(\\[[^]]*\\]);$', 'gm')
const str = `class1->Signal = sample1_sample2.sample3_sample4[4:4];
class2->Signal = sample1.sample2.sample3_sample4_sample5[2];
class3->Signal = sample1+sample2_sample3.sample4.sample5sample7[7:3];
class4->Signal = sample1[1]+sample2_sample3.sample4.sample5sample7[7:3];`;
const subst = `$1 bit = $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);