re = /^([^-]*)->.*?(\[[^]]*\]);$/m
str = 'class1->Signal = sample1_sample2.sample3_sample4[4:4];
class2->Signal = sample1.sample2.sample3_sample4_sample5[2];
class3->Signal = sample1+sample2_sample3.sample4.sample5sample7[7:3];
class4->Signal = sample1[1]+sample2_sample3.sample4.sample5sample7[7:3];'
subst = '$1 bit = $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result