# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?:names:)?\s*\(([^)]*)\)|name(s):)/$1/g;t' <<< "names:(taga || tagb || tagc)
names:tag1names: || names:tag2 || names:tag3
"