const regex = /(?:(?:names:)?\s*\(([^)]*)\)|name(s):)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:names:)?\\s*\\(([^)]*)\\)|name(s):)', 'g')
const str = `names:(taga || tagb || tagc)
names:tag1names: || names:tag2 || names:tag3
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);