#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?:names:)?\s*\(([^)]*)\)|name(s):)"
Local $sString = "names:(taga || tagb || tagc)" & @CRLF & _
"names:tag1names: || names:tag2 || names:tag3" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)