import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-zА-Яа-я0-9]+|[^A-Za-zА-Яа-я0-9]+";
final String string = "Популярные теги дня\n\n"
+ " javascript\n"
+ " JavaScript\n"
+ " 32k подписчиков 28k вопросов \n"
+ " php\n"
+ " PHP\n"
+ " 24k подписчиков 32k вопросов \n"
+ " html\n"
+ " HTML\n"
+ " 28k подписчиков 24k вопросов \n"
+ " css\n"
+ " CSS\n"
+ " 24k подписчиков 20k вопросов \n"
+ " веб-разработка\n"
+ " Веб-разработка\n"
+ " 24k подписчиков 8k вопросов \n"
+ " mysql\n"
+ " MySQL\n"
+ " 18k подписчиков 8k вопросов \n"
+ " jquery\n"
+ " jQuery\n"
+ " 23k подписчиков 12k вопросов \n"
+ " python\n"
+ " Python\n"
+ " 17k подписчиков 7k вопросов \n"
+ " wordpress\n"
+ " WordPress\n"
+ " 4k подписчиков 7k вопросов \n"
+ " программирование\n"
+ " Программирование\n"
+ " 25k подписчиков 8k вопросов \n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}