# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Za-zА-Яа-я0-9]+|[^A-Za-zА-Яа-я0-9]+"
test_str = ("Популярные теги дня\n\n"
" javascript\n"
" JavaScript\n"
" 32k подписчиков 28k вопросов \n"
" php\n"
" PHP\n"
" 24k подписчиков 32k вопросов \n"
" html\n"
" HTML\n"
" 28k подписчиков 24k вопросов \n"
" css\n"
" CSS\n"
" 24k подписчиков 20k вопросов \n"
" веб-разработка\n"
" Веб-разработка\n"
" 24k подписчиков 8k вопросов \n"
" mysql\n"
" MySQL\n"
" 18k подписчиков 8k вопросов \n"
" jquery\n"
" jQuery\n"
" 23k подписчиков 12k вопросов \n"
" python\n"
" Python\n"
" 17k подписчиков 7k вопросов \n"
" wordpress\n"
" WordPress\n"
" 4k подписчиков 7k вопросов \n"
" программирование\n"
" Программирование\n"
" 25k подписчиков 8k вопросов \n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.