$re = '/^(Con.+ess|Pul.+ole|RSI.+|VPN.+ulse|test|Users)/m';
$str = 'Consultants Special Access
Consultants Special EX
Contractors Windows Users Special Access
Contractors Windows Users Special Dix
PulseSAMRole
RSI - GIB Users
RSI - IT Desktop Users
RSI - ORA Devtrack
RSI - VPN ArchiveContractor Users
RSI - VPN Contractor Mac Users
RSI - VPN Contractor Users
RSI - VPN Contractor Users(Pulse)
RSI - VPN ITSecurity Users
RSI - VPN Users
test
Users
Contract Users
VPN Contractor Pulse
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);