re = /^(Con.+ess|Pul.+ole|RSI.+|VPN.+ulse|test|Users)/m
str = 'Consultants Special Access
Consultants Special EX
Contractors Windows Users Special Access
Contractors Windows Users Special Dix
PulseSAMRole
RSI - GIB Users
RSI - IT Desktop Users
RSI - ORA Devtrack
RSI - VPN ArchiveContractor Users
RSI - VPN Contractor Mac Users
RSI - VPN Contractor Users
RSI - VPN Contractor Users(Pulse)
RSI - VPN ITSecurity Users
RSI - VPN Users
test
Users
Contract Users
VPN Contractor Pulse
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end