# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[0-9]{13,14}|[0-9]{16}|[0-9]{18,20})$"
test_str = ("1\n"
"22\n"
"333\n"
"4444\n"
"55555\n"
"666666\n"
"7777777\n"
"88888888\n"
"999999999\n"
"1010101010\n"
"11111111111\n"
"121212121212\n"
"1313131313131\n"
"14141414141414\n"
"151515151515151\n"
"1616161616161616\n"
"17171717171717171\n"
"181818181818181818\n"
"1919191919191919191\n"
"20202020202020202020\n"
"212121212121212121212\n"
"2222222222222222222222\n"
"23232323232323232323232\n"
"242424242424242424242424\n"
"2525252525252525252525252")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.