// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-9]{13,14}|[0-9]{16}|[0-9]{18,20})$").unwrap();
let string = "1
22
333
4444
55555
666666
7777777
88888888
999999999
1010101010
11111111111
121212121212
1313131313131
14141414141414
151515151515151
1616161616161616
17171717171717171
181818181818181818
1919191919191919191
20202020202020202020
212121212121212121212
2222222222222222222222
23232323232323232323232
242424242424242424242424
2525252525252525252525252";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}