import Foundation
let pattern = #"^(?:[0-9]{13,14}|[0-9]{16}|[0-9]{18,20})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1
22
333
4444
55555
666666
7777777
88888888
999999999
1010101010
11111111111
121212121212
1313131313131
14141414141414
151515151515151
1616161616161616
17171717171717171
181818181818181818
1919191919191919191
20202020202020202020
212121212121212121212
2222222222222222222222
23232323232323232323232
242424242424242424242424
2525252525252525252525252
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)