re = /^(\w+)\s(\d+)\s([\d+]{2}:[\d+]{2}:[\d+]{2})\s\w+.\w+\s(\w+)\[(\d+)\]/m
str = 'Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end