package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?://[a-z0-9-]+(?:\.[a-z0-9-]+)*(?::[0-9]+)?(?:/[^\W\d]+(?:/\d+)?)?$`)
var str = `https://www.example.com
https://www.example.com/section
https://www.example.com/section/4
https://www.example.com/section/4/somethingelse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}