import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?://[a-z0-9-]+(?:\\.[a-z0-9-]+)*(?::[0-9]+)?(?:/[^\\W\\d]+(?:/\\d+)?)?$";
final String string = "https://www.example.com\n"
+ "https://www.example.com/section\n"
+ "https://www.example.com/section/4\n\n"
+ "https://www.example.com/section/4/somethingelse";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}