$re = '~^https?://[a-z0-9-]+(?:\.[a-z0-9-]+)*(?::[0-9]+)?(?:/[^\W\d]+(?:/\d+)?)?$~m';
$str = 'https://www.example.com
https://www.example.com/section
https://www.example.com/section/4
https://www.example.com/section/4/somethingelse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);