#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)DE\s+(3[01]|[12]\d|[1-9])\s+DE"
Local $sString = "DE 1 DE" & @CRLF & _
"DE 2 DE " & @CRLF & _
"DE 3 DE " & @CRLF & _
"DE 4 DE" & @CRLF & _
"DE 5 DE" & @CRLF & _
"DE 6 DE" & @CRLF & _
"DE 7 DE" & @CRLF & _
"DE 8 DE" & @CRLF & _
"DE 9 DE" & @CRLF & _
"DE 10 DE" & @CRLF & _
"DE 11 DE" & @CRLF & _
"DE 12 DE" & @CRLF & _
"DE 13 DE" & @CRLF & _
"DE 14 DE" & @CRLF & _
"DE 15 DE" & @CRLF & _
"DE 16 DE" & @CRLF & _
"DE 17 DE" & @CRLF & _
"DE 18 DE" & @CRLF & _
"DE 19 DE" & @CRLF & _
"DE 20 DE" & @CRLF & _
"DE 21 DE" & @CRLF & _
"DE 22 DE" & @CRLF & _
"DE 23 DE" & @CRLF & _
"DE 24 DE" & @CRLF & _
"DE 25 DE" & @CRLF & _
"DE 26 DE" & @CRLF & _
"DE 27 DE" & @CRLF & _
"DE 28 DE" & @CRLF & _
"DE 29 DE" & @CRLF & _
"DE 30 DE" & @CRLF & _
"DE 31 DE" & @CRLF & _
"DE 32 DE" & @CRLF & _
"DE 0 DE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")