import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "DE\\s+(3[01]|[12]\\d|[1-9])\\s+DE";
final String string = "DE 1 DE\n"
+ "DE 2 DE \n"
+ "DE 3 DE \n"
+ "DE 4 DE\n"
+ "DE 5 DE\n"
+ "DE 6 DE\n"
+ "DE 7 DE\n"
+ "DE 8 DE\n"
+ "DE 9 DE\n"
+ "DE 10 DE\n"
+ "DE 11 DE\n"
+ "DE 12 DE\n"
+ "DE 13 DE\n"
+ "DE 14 DE\n"
+ "DE 15 DE\n"
+ "DE 16 DE\n"
+ "DE 17 DE\n"
+ "DE 18 DE\n"
+ "DE 19 DE\n"
+ "DE 20 DE\n"
+ "DE 21 DE\n"
+ "DE 22 DE\n"
+ "DE 23 DE\n"
+ "DE 24 DE\n"
+ "DE 25 DE\n"
+ "DE 26 DE\n"
+ "DE 27 DE\n"
+ "DE 28 DE\n"
+ "DE 29 DE\n"
+ "DE 30 DE\n"
+ "DE 31 DE\n"
+ "DE 32 DE\n"
+ "DE 0 DE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}