package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*application.*`)
var str = `application
job application
applications
jobs applications
how do i get an application
where can i find a job application`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}