const regex = /^.*application.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*application.*', 'gm')
const str = `application
job application
applications
jobs applications
how do i get an application
where can i find a job application`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}