import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Description>[A-Za-z0-9 ×,\\.-]*)((?<weight>([0-9,.]+)(?<weightUnit>kg|G)))?.*?(?<heartbeat>([0-9,.]*))bpm";
final String string = "50y old guy living a 5th avenue with weight 50,5kg with heartbeat 90bpm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}