use strict;
my $str = '50y old guy living a 5th avenue with weight 50,5kg with heartbeat 90bpm';
my $regex = qr/(?<Description>[A-Za-z0-9 ×,\.-]*)((?<weight>([0-9,.]+)(?<weightUnit>kg|G)))?.*?(?<heartbeat>([0-9,.]*))bpm/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}