import Foundation
let pattern = #"(?<Description>[A-Za-z0-9 ×,\.-]*)((?<weight>([0-9,.]+)(?<weightUnit>kg|G)))?.*?(?<heartbeat>([0-9,.]*))bpm"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"50y old guy living a 5th avenue with weight 50,5kg with heartbeat 90bpm"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)